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Using Word 97 to Create Documents for an Intranet 
Lyn Robinson  
February 98 
 
______________________________________________________________________ 
 
 
Introduction 
Word 97 allows new and existing documents to be saved into html format. This file 
format (or more accurately coding), is used to mark up documents stored on part of 
the Internet known as the world wide web, or simply the web. In addition to text, these 
documents may contain multimedia elements, such as pictures, animation, audio and 
video, forms linking to information held in a spreadsheet or database, or programs 
known as applets or controls, which download with a document to run on a local 
machine. Documents can also contain hyperlinks, sections of text or graphics which 
when selected by the user, link to other related files. The linked files may be stored on a 
local or remote computer, the exact nature and location of which is  transparent to the 
user. Documents stored on the web can be accessed using a web browser such as 
Microsoft's Internet Explorer.  
 
The multimedia, hyperlinked, information space of the global web is also appealing to 
many organisations as a basis for their internal information systems. The model is easy to 
set up and use, offering an efficient and effective way to retrieve and disseminate 
information. Many companies have therefore decided to set up internal networks 
known as intranets, and to establish private webs, primarily designed for employees. 
Intranets support the TCP/IP communications protocol which runs over the Internet, and 
so it is possible, where desirable, to allow users on private intranets to connect to the 
public Internet, and also under controlled conditions to allow users connected to the 
Internet to access files held on an intranet.  
 
For more detail on intranets see Bernard 1998.  
 
 
HTML 
Documents created for webs contain coding known as hypertext markup language or 
html. These codes are made from simple text characters, and are used to instruct the 
web browser to display or interpret parts of a document in a particular way. For 
example, the following code indicates the start and finish of text which should be 
displayed as a top level heading: 
 

 
 
Another example shows the coding which indicates the location of an image file to be 
displayed within the document: 

 
Hyperlinks are inserted into a document by using codes which indicate the address or 
filename to which a hyperlink will jump, and whether the hyperlink is seen as a piece of 
underlined text or all or part of a graphic. The example below indicates that the 
hyperlink will be seen as Further information about the product, and when selected by  

<H1>This text forms a top level heading</H1> 

<IMG SRC="images/image.gif"> 
 

<A HREF="http://www.mycompany.co.uk/public/products/item.html">Further 
information about the product</A> 
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the user will display information from a file called item.html, located in the 
/public/products subdirectory on a computer belonging to mycompany.  
 
The colour and underlining of text hyperlinks can be set as a feature of the browser by 
the user, and so they will not necessarily appear as blue with underlining.  
 
Html codes can be written into a document using a text editor such as NotePad, or 
generated from the buttons and menus provided by specialised html editors such as 
HotMetal and HomeSite. Using a text editor requires knowledge of the codes, and so 
many people prefer to use html editors as features can be selected from menus and 
buttons, and applied to relevant parts of a document using the 'select then do' 
technique that is common for most wordprocessing applications.  
 
Html is a subset of sgml, standard general markup language, which is used in desktop 
publishing. Html standards are maintained by the world wide web consortium, 
(http://www.w3.org) which continually develops the code set, increasing the its 
functionality and sophistication. 
 
Further information on html codes can be found in Graham, 1996. 
(http://www.utoronto.ca/webdocs/HTMLdocs/book/book-2ed/book.html) 
 
 
Word 97 
Word offers a simple way to save new or existing documents into html. Simply create a 
document, or open an existing file, and then choose Save as HTML from the File menu. 
This option saves a new file directly into html, or will create an html formatted copy of 
any existing file. When displaying an html document, Word 97 provides additional tools 
for html authoring. During the conversion from Word format into html, Word attempts to 
map Word formatting onto an appropriate html code. Although many codes are 
supported, Word allows some text handling features which cannot be transcribed 
directly into html. Formatting that is not supported by html is not available in Word's web 
authoring environment. As a result, a file can have an unexpected appearance when 
converted to html and viewed under Word, or via a web browser. In most cases, some 
editing of the document will be required in order to ensure a smooth visual 
appearance. 
 
When working with an html file, Word  allows the web toolbar to be opened, which 
supports web related activities. These include opening and browsing of local 
documents,  and those on an intranet or the Internet. Word allows html files to be 
previewed under Internet Explorer, which is launched  by clicking the Web Page 
Preview button. This allows the result of edits to be seen as they would if the document 
was placed onto a web. It is possible to return to Word for further editing without closing 
Internet Explorer,  but changes made under Word will need to be saved and reloaded 
under Internet Explorer before their effect can be displayed.  
 
The major advantage to using Word is that html files can be created and edited with 
almost the same commands and options that are available when working with Word 
files. For example, inserting multimedia files or hyperlinks into an html file is a 
straightforward procedure under Word, by choosing options from the Insert menu. 
Additionally, features such as automatic spelling checking, autotext and autocorrect 
can also be used. This makes Word a sensible choice for  an organisation with a body of 
existing Word based documentation, or where staff already possess knowledge of 
Word.  
 
In order to create files which look completely aligned and polished under a browser 
however, some knowledge of html coding will be needed, as Word cannot convert all 
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aspects of a Word document into html. It is possible to view and edit the html coding 
directly under Word, by selecting HTML Source from the View menu.  
Using Word to Create HTML Files 
Word Help describes how to author html  documents using Word. Specifically, there is a 
description of formatting which will be lost during the conversion to html. (Search for 
Learn what happens when you save a Word 97 document as a Web page).  For current  
information on the web authoring features of Word 97, try the Microsoft support site on 
the Internet (http://www.microsoft.com). For further details of web document design, 
try Horton, Taylor, Ignacio and Hoft 1996.  
 
In addition, the following observations, based on practical experience may prove 
useful, although they do not claim to be comprehensive. 
 
General document design aspects 
• Try to start with as little formatting as possible when saving a Word file to html. The 

less formatting a document contains, the more easily it can be rendered into html. 
• Limit heading levels to three. Multiple heading levels make a document difficult to 

follow on paper and impossible to read from a screen.   
• Include a useful title within the <title></title> element of the html header. This title will 

display in the top title bar of the browser, and can be used be search engines to 
describe documents matching a query. It is not the page heading which comes in 
the body of the document and is displayed by the browser to the user. 

• Keep filenames in lowercase to avoid problems with mixed cases when creating 
links to files. 

 
Text formatting 
• Consider using a white document background for clarity, particularly if most of the 

document is text. Remember that by default, Internet Explorer will display a grey 
background, even though Word will show a white one. The background needs to 
be set explicitly under Word using Format, Background. 

• Specify a font which is easy to read on the screen such as Verdana. 
• Select html heading levels from the style box on Word's Formatting toolbar. These 

are indicated by the html codes H1 - H6. There are six heading levels supported by 
html. Remember that a heading is treated differently from the text within an html 
document.  

• Specify the font size of the text by selecting the text then applying the increase or 
decrease font buttons (large A/small A) from the toolbar. Html does not support 
exact point sizes of font; there are six html font sizes which are relative to each 
other.  

• Remember that html ignores multiple character spaces, line spacing and more than 
one carriage return between paragraphs. Html supports <br> for line feed and <p> 
for paragraph or carriage return plus line feed. Multiple codes are ignored. Word 
inserts a non-breaking space (&nbsp) to add extra white space between 
paragraphs. The spacing may not appear when the document is viewed under 
Internet Explorer however, and you may wish to add or delete the codes directly to 
achieve the desired spacing between document sections and paragraphs.  

• Bullet points should transfer smoothly from Word to html, but lists created by entering 
numbers, for a timetable for example, can appear skewed after saving to html. 
Remove manual numbering systems before saving to html, and replace afterwards. 

• Newspaper style columns are not supported by html. Text columns may be created 
by using the Table feature under Word, to set up a table without borders, into which 
text may be inserted. 

• Tabs are not supported by html, and are interpreted by Internet Explorer as spaces. 
Word converts tabs to the string &#9;, which can be seen in the source code, but 
which also appear as a space under Internet Explorer. When the tab key is used in 
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Word to edit an html document, Word help suggests using a table to align text 
instead. 

 
 
Multimedia Objects 
• Unlike a word document, which can contain embedded multimedia within a single 

file, html documents contain only the links (ie. address or filename) to the object file. 
The multimedia files must therefore be available in the specific location for the links 
to work. Use relative links (ie. a path relative to the current html document file) when 
the files will all be stored on the same server, but remember to preserve the 
directory structure when transferring the finished web document and associated 
files to the web server.  

• Inserted pictures and images will be aligned to the left by default, with the text 
beginning adjacent to the image border at the bottom right. To edit image 
alignment, choose Picture from the Format menu, and select required alignment. 
Note that it is also possible to improve the look of the document by specifying the 
amount of white space between an image and the text flowing around it.  

 
Hyperlinks 
• To insert a hyperlink to a separate file, place the cursor where the hyperlink should 

occur and select Hyperlink from the Insert menu. In the box labelled Link to file or 
URL, type or browse to the file to link to. This file may be on a local drive, network 
drive, or on the Internet. Click on OK. By default, hyperlinks will appear in the 
document as blue with underlining. Followed links will appear purple with 
underlining. The underlined text will be the  path+filename of the link. To create a 
link from more meaningful words, type in and select the required text before 
inserting the link. 

• Change the colour of hyperlinks and followed hyperlinks by using the Text Colours 
dialog box from the Format menu.  

• To create links within a document, first create a named place to jump to 
(bookmark), then create a link to it from anywhere else in the document. Place the 
cursor at the desired named location, and select Bookmark from the Insert menu. 
Type a name for the bookmark and click OK. To link to the bookmark, select the text 
or image to jump from, then choose Hyperlink from the Insert menu. Now choose 
the Named location in file box, and enter or browse to the desired bookmark. Click 
OK, then click OK again. The selected text will appear as a hyperlink, which when 
selected will jump to the named location. If no text or image is selected as the 
hyperlink, the name of the bookmark will appear instead. 

 
 
Document Creation Procedure 
Transferring an existing paper or electronic information system to a web based 
environment requires careful consideration. Documents created for reading on paper 
do not usually transfer directly to a screen based format, and some time must be spent 
on dividing files into suitable sections and creating appropriate links. Sometimes, 
additional document parts must be created  containing summary information or lists of 
sections to jump to. The following procedure outlines the stages which could be 
involved in the creation of documents for an intranet, using Word 97.   
 
1. Define Document Set 

• clarify documents needed for the intranet, and their purpose 
• identify any existing electronic or paper documents  
• agree any changes/updates required to existing documents 
• list any new documents required 
• draft contents for new documents 
• identify documents which require regular updating  
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• create a listing of the complete document set with respective author(s), date of 
publication and update frequency 

 
 
2. Design Overall Structure of Document Set for the Intranet 

• consider how the document set relates to other document sets within the 
organisation 

• consider the presentation of the document set on the screen, within frames for 
example, showing the list of documents (contents) on the left side of the screen 
and the contents of a selected document on the right 

• examine existing intranet/Internet documents for ideas and understanding if 
necessary 

• consider the creation of a 'title page' or starting point for the document set 
• identify any need for sub-listings from the main contents list 
• consider navigation amongst the document set, ie. how the reader can relate 

what is seen on the screen at any one time with the document set as a whole 
• consider links between documents 
• consider the directory and file structure which will represent the document set 

 
3. Design Structure of Each Document 

• divide individual document contents into sensible "chunks" and consider links 
within each document 

• consider file structure for each document; aim to keep files related to a 
document within the same directory 

• consider navigation within each document; plan to include routes back to the 
top, section listing, and main home page 

• consider image and graphic files needed; try to keep them small, to reduce 
loading time, and tasteful - remember less is often more. 

 
4. Create Word 97 Files  

• save existing document files into Word 97, make amendments as necessary and 
remove as much formatting as possible 

• create any new documents in Word 97 
• save sections of documents into separate files as decided in section 3 
• create title page to document set 
• create file of contents in Word 97, if using frames 
• create any sub-contents files required 

 
5. Create HTML Files 

• save the Word files as html (this option can be found on the Word File menu) 
• remember to keep copies of the original Word files 
• preview document under Internet Explorer  
• use web authoring features of  Word 97 to amend documents as needed 
• add multimedia objects 
• create required links within each document 
• apply appropriate 'house style' features, such as font, layout and graphics 
 

6. Move Documents to Web Server 
• liase with computing/information services as to directory structures/permissions 

needed 
• persuade colleagues to look at documents 
• remember to update documents regularly 
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